Hoffman72510
Baron
Baron
Posts: 159
Joined: Mon Jul 31, 2017 9:01 pm

Devs quick you broke the game!

Fri Aug 04, 2017 3:36 pm

The hospital update has caused myself and many, many others to lag and constantly have the loading icon for every simple action taken! Please fix!

P.S you just made dwarfs and Lich undead units even more worthless. Why not add a repair/revive feature?
 
User avatar
Flames
Baron
Baron
Posts: 141
Joined: Wed Jul 26, 2017 12:39 pm
Location: Belgium

Re: Devs quick you broke the game!

Fri Aug 04, 2017 4:06 pm

Thats weird, i don't have any problem at all.

Have you already restarted the game ?
 
Hoffman72510
Baron
Baron
Posts: 159
Joined: Mon Jul 31, 2017 9:01 pm

Re: Devs quick you broke the game!

Fri Aug 04, 2017 4:51 pm

Please ignore/delete. It either fixed itself or I overreacted. Just not used to lag lol!
 
User avatar
Flames
Baron
Baron
Posts: 141
Joined: Wed Jul 26, 2017 12:39 pm
Location: Belgium

Re: Devs quick you broke the game!

Fri Aug 04, 2017 5:37 pm

Hoffman72510 wrote:
Please ignore/delete. It either fixed itself or I overreacted. Just not used to lag lol!


Haha, okay!
Even better, have fun again. :P

Can a mod close this ?
 
Hisoka
Baron
Baron
Posts: 245
Joined: Thu Jul 27, 2017 9:53 pm

Re: Devs quick you broke the game!

Sat Aug 05, 2017 12:42 am

Yeah had same issue same with housemembers but it fixed now, im guessing host lag from the update temporarily

Who is online

Users browsing this forum: No registered users and 2 guests